Grading — Civil 3D

The objective in grading is to build a proposed surface using points, feature lines, polylines, and gradings. Then
you may calculate volumes comparing it to the existing surface.

1. Right-click “Sites” > New

2. Dig into the site and right-click “Grading Groups” > New

B@ Sites

=By PKLot Site
--"::3' Alignments
J Feature Lines

..... i) w_
----- %ﬂ Parcel: m
@E Catchments Refresh

3. Checking the “Automatic Surface Creation” box is extremely useful as gradings are automatically added

to the surface, but it comes with some risk. Complicated grading projects can cause slowness and
possible crashes.

Create Grading Group bt
MName:

| Parking Lot Eﬂ]
Description:

Automatic surface creation
Use the Group Name
Surface style:
|f} Contours 1"and 5 {Design) vl P

Tessellation spadng:

10,00°

Tessellation angle:

Volume base surface

Cancel Help

4. Now using points, features lines, 2D polylines, 3D polylines, or Gradings, add the necessary data to the
surface, under the definition.
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This figure below shows the path one can take to create and modify different entities. There are advantages and
disadvantages to each type of entity. By far, the most versatile are feature lines. You may convert these entities
following the arrows below.

Home tab = Feature Line = Create
Feature Line From Objects

2D Polylines

(Contours)
Eaaticaliias Modify tab = Design =
Modify tab = Design = Convert 2D to 3D
Convert 3D to 2D Polylines
Polylines
Home tab = Feature
Line = Create Feature
Line From Objects

3D Polylines

Explode

The figure below explains the general workflow when adding data to a surface when using the grading tools.

GRADING
GROUP »

/ Added
Automatically

Gradings

\ YES

Automatic

Surface '*

Creation

SITE —> SURFACE

Feature
Lines

Add to Surface as Breaklines
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Feature Lines

A thorough explanation of feature line commands exists in the advanced manual. Please refer to that for
additional information. The feature line commands can be found in the Grading pulldown or on ribbons.

|

@* Create Grading... @ Create Grading...
@ Create Grading Infil @ Create Grading Infill
f_j Draw Feature Line f’j Draw Feature Line
L_}) Create Feature Lines fram Objects r—:_';) Create Feature Lines from Objects
“%f Create Feature Lines From Alignment “ Creats Feature Lines from alignment
% Quick Profile. . ™. Quick Prafile. .,
Edit Grading * Edit Grading 4
Edit Feature Line Elevations 4 Edit Feature Line El ions [0 Elevation Editar. ..
Edit Feature Lin HZ_.; Insert PI Edit Feature Line Geometry 4 ;{,.v* Quick Elevation Edit
Add Feature Line Labels * Vé ;):::3 . Add Feature Line Labels ¥ TF Edit Elevations
Add Tables LR o Add Tables L4 ﬁ' Set Grade[slope between Points
el Trim + i )
Grading Utilities 3 Q‘\T Join Grading Litiities N ;i Insert Elevatl.on P0|!1t
Palding Utilities ¥ Reverse Pabyine Ukilities y | +© Delete Eleyation Point
+J Insert High/Low Elevation Paint
J Edit Curve +17 Raise/Lower
o Fillet
A Bt Crve :_\.J Set Elevation by Reference
S Smoath 3?3 Raise/Lower by Reference
..:?t weed ﬁ Adjacent Elevations by Reference

;_’,7 Stepped Offset \ Grade Extension by Reference

% Elevations from Surface

Home Insert Annotate [ESGGHTE  Analyze Output  Manage  Bxprg
ﬁ Survey Parcel "% Alignment * Intersaction m Profile View

=§> Points X Profile ,-_% Assembly E] —h sample Line
@ Surface ® Grading Carridor Fﬂ Pipe Metwaork Q Section View
Ground Data Design - Profile & Section Views

Annotate  Modify Analyze View Output Manage Express Tools Image — Shds Manager [Raecid ARG

. Properties -r_ -r_ ﬁlb" Add to Surface as Breakline \\,/
% D Fa [&] [o] —sh @*’ Grading Creation Tocls X
L_' Object Viewer . . . I?I; Apply Feature Line Names .
Add  Renumber Feature Line Edit Edit Quick Ié_i:ﬁ' Create Surface Close
Lat:-elsv Tables+  Tags Cb Isolate Objects Properties ™ |Geometry Elevations %j Apply Feature Line Styles Profile
Labels & Tables General Tools ﬁ Modify Launch Pad Close
i

Use these to open the panels in
the Feature Line ribbon tab.
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Points

Select the Point Creation Tools under the Home tab of the ribbon.

LU Insert  Annotate  Modify  Analyze  View  Output

x @Wﬁn Q Import Survey Data @ Parcel = ":;*; Al
Toolspace|ﬁ|@| @E Points v| f) Feature Line ~ f Pr
ﬁ @' Paint Creation Tools

Palettes « | Create Points - Miscellanecus »

Create Points - Intersections »

Create Points - Alignments 3

Create Points - Surface 3

Create Points - Slope »

Crzate Points - Intarpolate 3

[{.ﬁ' Create Point Group

Create COGO Points from Corridor

i 47

Create Blocks frem COGO Points

£
Al

Convert Land Desktop Paints
Convert AutoCAD Points

40 7

Replace Scftdesk Point Blocks

Create Points ;,_‘:? @ X

Select a command from the point creation tocls

&«

Create Points on a Surface

Create Points R X
f- 8- ©-BH - BB ¥
Select a command from th E\@x |
On Grid
@ Aleng Polyline/Contour
l?:h Polyline/Contour Vertices

e Random Points - This command reads the current surface, and the user picks an x,y location in the

drawing and the command will enter the elevation based on the surface.

e On Grid - This command will prompt for rotation angle, X, and y spacing to place points in the same

fashion as the ‘Random Points’ command.

e Along Polyline/Contour - This command places points based on a surface elevation along a polyline.

The command prompts for spacing.

e Polyline/Contour Vertices - This command places a point on each vertex of a polyline, this will not

read the surface elevation.

There is also a command to change existing points to the elevation of the surface.
Points > Edit > Elevations from Surface
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Create Points based on Slope

Create Points (5
R N ok v

Select a command from the point creation ¥ High/Low Point |

@ Slope/Grade - Distance
Slope/Grade - Elevation

e Slope/Grade — Distance - The user picks a starting point, then a second point which denotes direction &
distance, then chooses a slope or grade with several intermediate points.

e Slope/Grade — Elevation - The user picks a starting point then a second point which denotes just
direction. The user then choosing grade/slope and elevation to end.

e High/Low Point - The user picks a start point then a second point. The user will be prompted from
each point the desired grade or slope to find the intersection.

Create Points by Interpolation

Create Points i X
fv @y v G- BB B ¥

Select a cornmand from the point 4 ?ﬂk ¥ Interpolate

By Relative Location
By Relative Elevation
MNumber By Distance
Perpendicular
Incremental Distance

Incremental Elevation

Intersection

e Interpolate - The user picks two Point objects and enters the number of intermediate points they
desire.

¢ By Relative Location - The user establishes two points then is prompted for a distance to place a point
FROM the first point along the line defined by the initial two points.

¢ By Relative Elevation - The user established the two points then is prompted for an elevation between
two points and the computer places the point at that elevation along the slope defined by the two points.

e Number By Distance - Same command as ‘interpolate’ except the user has more versatility in
choosing the two points (i.e. you are not limited to Point objects).

e Perpendicular - The user picks two points to establish a line, then the user picks any point on the
screen and the computer calculates the perpendicular point where it crosses the initial two points
defined line then places a point at the correct elevation based on the slope of the initial points.

e Incremental Distance - The user established two points with elevation and then is prompted for the
increment to set points.

e Incremental Elevation - The user establishes two points with elevation and then is prompted for the
elevation increment to place points along the sloped line.

e Intersection - The user two points to define the first line then two points to define the second line. The
user is prompted for the desired offset to each line and will place a point at that location.
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Daylighting

In Civil 3D, there is only one way to daylight to a surface; using Gradings.

1. Select Grading Creation Tools from the Home tab of the ribbon

GGG Insert  Annotate Modify Analyze View  Output

4 Import Survey Data | &5 Parcel + =t Alignim
52 R 2 i

ﬁ :ﬁ Points = f)’ Featura Line - l* Profile
Eff Surfaces = @ Grading * ﬁ Corrida

Palettes Create Ground Data : i
Grading Creation Taaols

@ Create Grading Infill
5
m Create Grading Group

Toolspace

Choose the Choose the Select the "Create
daylight surface. desired criterion. Grading" option.
Gradfnf\ion Tools r R X
] £ | (B (T Cut Slope Display - 7 v BB E
Pararneter Value @}
B Grading Method ﬁ;} Copy Create Grading
Target Surface @ Create Transition
Projection Cut/Fill Slope (B  Createlnfil
Search Order Cut first &
El Cut Slope Projection {up)
Format Slope &
Slope 2.00:1 &
B Fill Slope Projection (down)
Format Slope &
Slope 2001 &
B Conflict Resolution
Interior Corner Overlap Use Average Slope &
Cut Slope Style:
[ Fil Slope Display - B~
Group: Parking Lot Surface: 0G

a. Select the object to daylight from. This must be a feature line in the same site as the grading
group.

b. Select the side to search for the daylight surface.

c. Apply to entire length? [Yes/No] <Yes>: This question applies if you wish to add transition
slopes along a feature. For example, part of the way I need to slope at 2:1, for another part it
needs to be 4:1, and then I need to transition the slope between the regions.

d. Hitting <enter> out of the command adds the grading object to the surface supplied when you

created the surface through creating the grading group (unless automatic surface generation for
the grading group is not checked).
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Volumes

“Analyze” tab > Volumes Dashboard

Analyze

(@) Q @ ':_::'s Edit in Storm Sewers [ | ’ Volume Report Compute Matenals
v L4

2 Analyze Gravity Metwork o @ Total Yolume Table 4% Mass Haul

Visibility  Drive Interference Velumes Dashboard Grading Volume .
Check Check Tools @ Material Volume Table ;H: Earthwork Plan Production
Design = Volurnes and Materials

‘ Create a new volume surface

X

JLEX: cw A @
oy MName B Mid-Ordinate... Cut Fact Fill Factor Style 2d Area(5q. Ft)  Cut{adjusted){Cu. ... Filliadjusted)(Cu. ..  Net(adjusted)(Cu.... Net Graph
B Create Surface X
Type: Surface layer:
TIN volume surface ~ | | C-TOPO g
2
= Properties Value
2 E Information
= Mame Parking Lot Volume
B Description Description
. Style _Mo Display
Render Material _Mo Display
B Volume surfaces
Base Surface Existing Ground
Comparison Surface Parking Lot
Cut Factor 1.000
Fill Factor 1.000

C' Selecting OK will create a new surface which will appear in the list of surfaces in Prospector.

L ]
Cancel elp

Other Options from the Volumes Dashboard

e Add aclosed object in AutoCAD to use the bounded volumes option. This will calculate the volumes
for a closed area instead of the entire surface.

e Generate Cut/Fill Report - this creates an xml report opened in the default Web Browser.

e Insert Cut/Fill Summary - This creates an AutoCAD entity in the drawing instead of an external report.
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“Analyze” tab > Grading Volume Tools

Raise and lower the
grading features.

Balance Volumes

Grading ¥olume Tools
[&] [I? (%) Entire Group ) Selection Cli'r @ Q | 3.000° | s
Cut: Fill: hetk:
21945.24 Cu, ¥d, || 6.76 Cu. vd. | Cut: 21938.49 Cu, vd.
Histary:
Cuk Fill Met Description
1 21945,24 Cu, vd. /.76 Cu, ¥d, Cut: 21938.49 Cu, ¥d, Group lowered 3,000
2 349,00 Cu, Yd. 1217713 Cu. ¥d, Fill: 11828.12 Cu, ¥d. Group lowered 4,000

3 0.00 Cu, ¥d.

58676.45 Cu. Yd.

Fill: 58676.45 Cu. ¥d.

Group: Grading Group 1

raising and lowering the grading features.

Shows the history of changes made

© 2025 CAD Masters, Inc. All rights reserved.

S CAD

MASTERS

https://cadmasters.com/resources/#c3d-cheat-sheets




